Announcing mail-send, a Rust e-mail delivery library with DKIM support
Hi,
Just wanted to announce that mail-send was released today, which is an alternative to lettre but with fewer dependencies and some additional features:
- Generates e-mail messages conforming to the Internet Message Format standard (RFC 5322).
- Full MIME support (RFC 2045 - 2049) with automatic selection of the most optimal encoding for each message body part.
- DomainKeys Identified Mail (DKIM) Signatures (RFC 6376).
- SMTP support.
- Secure delivery over TLS.
- Authentication with automatic mechanism selection (XOAUTH2, CRAM-MD5, DIGEST-MD5, LOGIN and PLAIN are supported).
- Third party e-mail delivery:
- Mailchimp
- Mailgun
- Others to follow.
- Full async (requires Tokio, other executors can be added upon request).
In addition to this library you may also want to check out mail-parser (released some months ago) which supports parsing MIME messages in 41 different encodings.
Hope you find them useful!